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1.1,2,3 
 

 
Launch the Application from the 
desktop (Desktop icon). A signing 
pencil. 
 
 

Start Menu 
 
Start=>All Programs=>Datarizer 
Inc=>Datarizer eSignature 
Gratis=>Datarizer eSignature 
Gratis 

 
Datarizer eSignature Gratis Logo 
 

 
 
 

 
 
 
 
 
 
 
 

 

Application Overview 
 
1.1  What is Datarizer eSignature Gratis? 
 
Datarizer eSignature Gratis is the free version of Datarizer eSignature which 
enables electronic signing and validation of PDF documents completely free of 
charge. 
 
Datarizer eSignature Gratis is a software application (or system) that enables 
online signing and validation of PDF documents across the internet. It is native 
application with a small client and big server arrangement. It is also a cloud 
application with client side software for better user experience and rich 
interactive User Interface (UI). It was designed with a simple concept in mind to 
mimic traditional signing on paper to make it simple and user-friendly. Datarizer 
eSignature is free. Only PDF documents can be signed with Datarizer 
eSignature Gratis. 
 
1.2  Why PDF Documents? 
 
PDF stands for Portable Document Format. PDF was in existence since 1991 
and had stood the software compatibility test of time across different platforms 
until to date. It was outlined by Adobe System, cofounder “John Warnock”. The 
major problem that is solved was document compatibility and quality across 
different platforms. 
 
Applications compatibility and their associated files is still a major concern today. 
Software vendors continue to upgrade and develop new applications and in time 
compatibility is lost with older versions. This is a huge concern to electronic 
signing of documents, because legal documents must be kept and be accessible 
for many years. 
 
Datarizer eSignature will keep documents for 25 years before permanent 
deletion with consultation with the originator. 
 
 
1.3  How is it different from other electronic and digital signature 
software? 
 
Datarizer eSignature Gratis blends both electronic and digital nature of 
signatures into one, without pushing the complexities to the user. The weakest 
link in any secure system is always the user (the human element). See the next 
sub-section for more insight on security. 
 
It complies with the KISS principle, it is simple, user-friendly and affordable to all. 
Signed document does not need to be transmitted through emails (SMTP) as 
this transmission takes place in the system. 
 
Datarizer eSignature Gratis serves only the copies and never the original 
document to prevent tampering with the document. The original document is 
broken down and kept in the database and used together with all the signatures 
and device used to sign to form the #hash or digital nature of the final document. 
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Datarizer eSignature Gratis Logo 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This digital nature of the document cannot be forged. When a document is 
validated, this digital nature is used to check document that is being validated. If 
the document was changed in anyway, it will never validate true. Validation must 
be done using the Datarizer eSignature Gratis as it contains the original 
document with the original digital nature. The safest and secure place to store 
data or documents is in the database. 
 
Document copies can only be served to the devices (computer, laptop etc) that 
are in the workflow as stipulated originally when the document was uploaded. 
NB: The document can never be listed, appear or served to the device which is 
not in the document workflow.  
 
Datarizer eSignature Gratis is completely independent from Adobe Reader 
application. The technology that is used to sign the documents is on a file level 
and not on application level unlike the other electronic signature softwares. This 
prevents any compatibility issues that may arise in future.  
 
If your device is stolen, call Datarizer Inc. and have all your documents linked to 
the new device. Your stolen device will be deactivated and wait for thief to come 
back and be caught. Even if the device is reformatted and reloaded with new 
OS, the thief will still be caught because the device hardware was not changed. 
This is the part that improves the security of the application (or system). 
 
No peripheral are necessary such as expensive signing pads and pointers or 
pens. Use what is already available such as Paint application and scanners. 
 
Datarizer eSignature Gratis offers the same freedom that one currently enjoys 
with PDF documents. Once the Document copy is served to the user, the user 
can do as they wish, that is, send it to whoever by email, delete it and archive it.  
Save time and money. Documents can be transmitted, signed within minutes 
across the globe, safely and securely. If a document is tempered with, it will be 
detected during the validation process. 
 
All software updates are done online, meaning bugs and upgrades can be done 
quickly and efficiently. The fix or upgrade is as close as your next launch of the 
application. What a quick turnaround time. 
 
It is 100% paperless. The option to print is still available but not needed. This is 
the freedom you have with the Adobe Reader. 
 
Datarizer eSignature Gratis does not sign PDF documents that have been 
locked by a password for modification as this constitutes unethical behavior.  
 
 
1.4  Authentication security formula 
 
The authentication security formula can best be presented mathematically as:- 
 
Security = Function∫(Device, PIN, SSL, Visual eSignature, Document Digital 
Nature (#hash function algorithm), Validation code Technology, 3 times login 
failure lockout) 
 
Datarizer eSignature also uses COMODO for an increased security online. 
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Datarizer eSignature Gratis uses the device that was used to sign in the security 
formula to limit the weakness of the user on security matters. For instance, if the 
login credential (PIN) of the user was hacked or phished, the Hacker will still not 
be able to log in the system despite applying the correct credential.  
 
Secure Socket Layer (SSL) technology is used to connect the client and server 
devices through the security pipe. 
 
The only place to keep data and documents/files secure is inside the database 
and nowhere else. The Database security permission should be reduced to the 
absolute minimum.  
 
The Digital nature of the document is the complex mathematical computation 
algorithm that is done on the final document to produce a hash number which is 
so unique and cannot be reproduced again by using a different document. 

 
Private Key ≈ Function∫(Device, Login Credentials, Document Digital Nature, 
SSL) 
Public Key ≈ Function∫(Device, Document Digital Nature, SSL) 
 
It is a security risk to explain beyond this level. This information is adequate to 
ensure that security has been taken care of to a reasonable extent. 
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Definitions and Abbreviations 
 
Application/System 
Both words are used interchangeably in Datarizer eSignature Gratis. For simplicity 
they both mean application. However, system is much complex and bigger than 
application because of many devices connected together through the internet with big 
back end RDBMS. 
 
Device 
Device could be a computer Laptop, Notebook, Mobile smart phone, Desktop 
computer, Mac, iPad, Tablet, Surface. Any machine consisting of a processor, hard 
drive, screen and input devices (such as keyboard) and is capable of running this 
application as per the system requirements. 
(NB: In future it will be possible to run Datarizer eSignature on all devices. Currently it 
only runs on Windows operating platform.) 
 
Electronic Signature and Digital Signature 
See general legal definitions in the next Section 3. 
 
Device Stamp 
It is a software independent unique code of the device. 
 
Device Signature 
It is a software independent unique serial number of the device. 
 
Validation 
A thorough computation process of looking at a smallest piece of a computer file, one 
by one, using a digital magnifying glass to ensure that the two files are exact match 
beyond reasonable doubt. 
 
Authentication 
A computation process or means of identifying users and devices, and verifying their 
eligibility before access is given into the system or application on the correct devices. 
 
TRANS 
It is verb and also a document status, meaning to change a document into a state 
where no further changes are allowed. This status “TRANS” gives a document its 
original value. The document in this state cannot be signed any further. NB: It is 
important that all the signatories sign the document before it is TRANS’d or else, no 
more signatures will be allowed. The last signatory must check if all have signed 
before clicking the “TRANS” button on the toolbar menu. 
 
SSL: Cryptography Secure Socket Layer technology 
 
UI: User Interface 
 
PDF: Portable Document Format 
 
RDBMS: Relational Database Management System. Database 

system such as Oracles, MYSQL, Postgre, MS SQL 
Server, DB2 etc. 

 
KISS Keep It Simple Stupid principle. 
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Legality of eSignatures 
 
The digital age came along with an increase in digital information and in other 
cases it is no longer possible to sign using the traditional pen and paper. Things 
are happening quite fast. Imagine having to print a form, fill it in, sign it, scan it 
back into the computer and send it by email. Sometimes, the scan copy is not 
accepted, which means the original copy must be posted or transported where it is 
required. It cost time and money to do transact in this manner. Imagine buying 
shares online and receiving and signing the contract online immediately. This is 
efficient. 
 
Governments all over the world have realized the role that electronic and digital 
signatures plays in the digital or information age. There is no turning back. 
 
Electronic signature and digital signatures are legal in many countries, even 
though, not all countries have proper legislation in place to control the boundaries 
of electronic and digital signatures. 
 
What is the difference between Electronic and Digital signatures? 
 
Electronic Signatures 
An electronic signature is a signature that consists visual form on a screen or 
print, characterized by a digital form incorporated in and attached to or associated 
with an electronic document. 
A secure electronic signature is as an electronic signature that:- 
• is unique to the person making the signature; 
• the technology or process used to make the signature is under the sole 

control of the person making the signature; 
• the technology or process can be used to identify the person using the 

technology or process; and 
• the electronic signature can be linked with an electronic document in such a 

way that it can be used to determine whether the electronic document has 
been changed since the electronic signature was incorporated in, attached to 
or associated with the electronic document. 

 
Digital Signatures 
A digital signature is a mathematical scheme for demonstrating the authenticity of 
a digital message or document. A valid digital signature gives a recipient reason to 
believe that the message was created by a known sender, such that the sender 
cannot deny having sent the message (authentication and non-repudiation) and 
that the message was not altered in transit (integrity). Digital signatures are 
commonly used for software distribution, financial transactions, and in other cases 
where it is important to detect forgery or tampering. It involves the Cryptography 
technology. This signature does not have a visual form. 
 
 
The concept of a legal Electronic/Digital signature 
Many countries retain the following general rules to govern the use of electronic 
and digital signatures.  
 

1. Intent to sign. The signature is valid only if the signatory had the intent to 
sign. 
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2. The signatory MUST do the signing personally.  
3. Notarization. It should be possible to certify, attest or authenticate that the 

signature or the entire document is legitimate. 
4. The signature or the electronically/digitally signed document should keep 

an associated record to reflect the electronic process that was used to sign 
it. 

5. Document retention. The signed documents (records) should be kept safe 
for a reasonable time period and the ability to reproduce them at a later 
stage to all concerned parties. 

6. The capability of the electronic/digital process to prevent or expose the 
document forgery should this happen. 

 
If the electronic or digital signature process covers the above, it will be adequate to 
ensure a safe and reliable usage of electronic or digital signatures. 
 
It is important to note that, the electronic/digital process attempts to mimic or better 
the traditional ink on paper process which is simple enough for the average John 
Doe. The average John Doe should not be bombarded by complex computational 
algorithms to ensure the implementation of the above six points. The electronic 
digital process should use the complex computational algorithm information to 
apply to the six points and provide simplistic information that can be understood by 
the average John Doe.  
  
 
The future of Electronic Signatures 
 
Countries are busy putting or perfecting their legislation to govern the use of 
electronic/digital signatures. Amongst others are, just to mention a few:- 
 

• South Africa – Electronic Communication and Transactions Act 25 of 2002. 
• United States – Electronic Signature in Global and National Commerce Act 

of 2000. 
• United States – Uniform Electronic Transaction Act or 1999 (UETA). 
• United Kingdom – UK Electronic Communication Act of 2000. 
• United Nations - UNCITRAL Model Law on Electronic Commerce of 1996. 

 
 
The amount of electronic transactions and electronic information has vastly 
increased to an extent that this cannot be ignored but to be made better to work in 
all electronic transactional scenarios. Every country is working on to adopt some 
kind of electronic signature law. 
 
All the software vendors supplying the electronic signature software must ultimately 
come together to produce one acceptable software that is acceptable globally by 
all. 
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Application User Interface (UI) 
 
The User Interface is simple and user-friendly. Signing a document is four clicks 
away. 

1. Indicate whether you are signing a “New” or a “Signed” document. 
2. Select to “Sign All Pages” or to “Sign Last Page”. 
3. Select or Type your signing capacity. 
4. Click “Sign Document” button. 

That is all to signing a document using Datarizer eSignature software. See figure 1 
below. 
 

 
Figure 1 – Datarizer eSignature Gratis main screen 
 
The PIN (Personal Identification Number) is required to gain access into the 
system. The User must log in on the device where he/she has registered the 
signing credentials. The device is partially authenticating the user as well. There 
are no Licence Fees and Service Accounts. See figure 2 Below. 
 

 
Figure 2 – Login screen (First window) 
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Figure 1 above shows the Device Stamp and Device Signature of a particular 
unique machine or device. This is unique and there is no other device with the 
same numbers or codes. It also indicates the visual electronic signature that will be 
included attached on the signed document. All these together form a unique digital 
pen that is used to sign the document. In the algorithm function, the Device Stamp 
and Device signature serves more or less the same purpose as Private Key and 
Public Key functions in the digital signature process. This is all coded in the 
application software.  
 
The Device Stamp and Device Signature are not software dependant but hardware 
dependant. Even if the software is changed, these two codes will remain the same. 
 
 

 
Figure 3 – PDF Document before it is signed 
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Figure 4 – PDF Document after it was signed 
 
Figure 3 and 4 above shows an unsigned and a signed PDF documents 
respectively. All the 114 pages were signed. 
 

 
Figure 5 – Zoomed-in details of the signature 
 
There is a transcript written vertically, along the document on the right hand side of 
the signed document which states  
“Datarizer eSignature 206807587 (Document Number: 127) Page 4”. See figure 4 above. 
 
It is clear that this document was signed using Datarizer eSignature and the 
Document Number is a reference back to the application. 
 
The signature above in figure 5 also contains some useful information such as 
Signing Capacity, Signatory, Designation, Date and Time and the Device that was 
used to sign the document.  
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System Requirements 
 
Datarizer eSignature Gratis runs on Microsoft Windows Operating System (OS). 
 

Windows Operating Systems 

 
1. Windows XP 
2. Windows Vista 
3. Windows 7 
4. Windows 8 (??? Very unstable. Special development in this area is in 

progress) 
 

System Minimum Disk 
Space RAM Processor 

32 bit 600MB 512MB 1GHz 
64 bit 1.5GB 512MB 1GHz 

 
This application is supported by .NET Framework 4.0 
 
 
Future Developments 
 
Development is underway to bring this application to run on other platforms, such 
as iOS, Mobile Platforms (sambian), Linux etc. Some of the problematic platforms 
will be dealt through HTML and other scripting languages such as JavaScript and 
PHP. The challenge is always to bring the same security features as currently as in 
the Windows platform. Security will not be compromised. 
 
The server side will not be changed with exception of scaling it up to store more 
data. 
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How to? Everything 
 
6.1  Get Security and Certification Authority Information? 
 
Software Certificate was issued by COMODO. https://www.comodo.com 

 
 
The SSL certificate for secure connection between Server and Client machines 
was also issued by COMODO. 
________________________________________________________________ 
 
 
6.2  Create and upload your Electronic Signature? 
 
All you need to create your Electronic Signature is a scanner, a paint brush 
application, pen and white piece of paper. 
 
Signature Dimensions 
 
Your signature should be 2cm X 7cm or 20mm X 70mm. 
 

 
Figure 6 – Electronic Signature dimensions 
 
 
Follow these steps to create your signature:- 
 

1. Take an A4 size paper and mark out the dimension of 70mm X 20mm. 
2. Sign inside the mark as shown in figure 18 above. 
3. Cut out your signature out with scissors. 
4. Scan the signature image into a PDF. 
5. Open the signature image and set PDF zoom to 100%. 
6. Use the PDF Snapshot tool to select the image and copy to clipboard. 
7. Open the Paint application. Start Menu=>All Programs=>Accessories. 
8. Click menu “Image=>Attributes”. 
9. Set Width = 305 Pixels and Height = 85 Pixels as shown in figure 7 

below. 
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Figure 7 – Paint Brush menu “Image=>Attributes” 

 
10. Click “Ok” button. 
11. Click menu “Edit=>Paste” or “Ctrl + V” on the keyboard to paste. 
12. The signature image should be in paint. Tip: Real size image. Take your 

paper signature and put it on the screen to check. 
13. Save this image as *.jpg or *.tif or *.png. 
14. Click menu “File=>Save As”. Select the suitable file name and ensure 

that “Save as type” is selected as *.jpg or *.tif or *.png. 
15. Click the “Save” button. 
16. Your signature is done and ready to be uploaded. 

 
 

17. Launch Datarizer eSignature Gratis application. 
18. Login. 
19. Click toolbar “Signature=>Update”. 
20. Browse and find your newly created image signature. Select it and Click 

“Ok” button. 
21. Your signature is done and will appear at the bottom. 

_______________________________________________________________ 
 
 
6.3  Sign a PDF document? 
 
It takes only four clicks to sign a document. Our previous example in sub-section 
9.4 uploaded a “Document Number 129”. This document will be signed in this sub 
section. Follow the these steps:- 
 

1. Log in by entering your PIN. 
2. Select the document to sign in “Documents to be signed” tab. The top 

section list. Take note, there is top and bottom document lists. 
3. There are three selections on the toolbar menu. Refer to figure 8 below:- 

a. Select “New” if you are signing new document (top list). Always 
select “New” for all documents in the “Documents to be signed” 
tab of the top section. This is the first signature. Select “Signed” if 
you are signing a signed document which is listed at the bottom 
of the “Document to be signed” tab. In case more signatures 
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needs to be attached. 
b. Select which pages to sign. Select “Sign All Pages” or “Sign Last 

Page”. Signature will always appear at the bottom of the page. 
c. Select the signing capacity or authority. You can either type it or 

select from the list. (Authorizer; Approver; Accepted By; Witness; 
Compiler). 

4. Click “Sign Document” button. 
5. The signed document will appear at the bottom list of the “Documents to 

be Signed” tab. 

 
Figure 8 – How to sign a document 
 

6. When all the Signatories have signed the document. The last Signatory 
to sign must click “TRANS” button on the toolbar menu. 

7. The TRANS process will move the document/s from the “Documents to 
be signed” tab (bottom list) to the next tab “All Documents”. This process 
is irreversible. 

8. Document signing is completed. 
 

 
Figure 9 – Document signed message 
 
NB: Once the “TRANS” button is clicked, no further changes or any signing can 
be done on the document. The document is sealed forever. It is important to note 
that this button is not clicked unless all the signatories have signed the document. 
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This could have been coded in but it was left out for a very obvious reason. 
 
6.4  Validate a document? 
 
Datarizer eSignature validates all external PDF documents with a reference to 
itself, meaning, if a document was signed using Datarizer eSignature, it can be 
validated to check authenticity of the document. Validation is universal, it can be 
done on any device running Datarizer eSignature. 
 
Validation is: True, means that the external document is the copy of the original 
document in the system and no changes has been made. It is authentic. If a 
document is validated to be true, Datarizer eSignature will serve a Document 
Number and depending on the document work flow, the document may or may 
not be served to the device. If you have a Document Number, you can call the 
document using the document search. If you are not on the correct device the 
document will not be served to the device. 
 
Validation is: False, means that the document does not exist or changes were 
made. The external document copy was not signed using the Datarizer 
eSignature or it is a fraud or forgery. Follow these steps to validate a document:- 
 
The Validation process is of a digital nature applying a complex mathematical 
algorithm. Follow these steps to validate a document:- 
 

1. Click menu “Document=>Validate” or press F2 on the keyboard. 
2. Select the external document or file to validate. Click “Open” button. 
3. Wait for Validation message/s to return. See figure 10 and 11 below for a 

True and False validation messages respectively. 
 

 
Figure 10 – Validation True 

 
Figure 11 – Validation False 

 

 
Figure 12 – The document does not exist 
 
It is absolutely not possible for the digital validation process to validate and 
process the documents incorrectly. If this happens, it will give another error 
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Launch the Application from the 
desktop (Desktop icon). A signing 
pencil. 

 
Datarizer eSignature Gratis Logo 

 

Download Datarizer eSignature Gratis 
 
Software certificate was issued by COMODO. https://www.comodo.com 

 
 
 
Down load the software from www.datarizer.co.za/Datarizer_eSignature.htm. 
Click on the download link and follow the download steps as provided. 
Downloading is simple.  
 
There are no complex settings that the user must enter. 
 
Even though you get a Desktop icon to launch the application, Datarizer 
eSignature is a pure internet based application running on the server and a small 
part temporarily running on the client machine. 
 
Watch a YouTube video at http://youtu.be/llAaAgOCSWo 
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Contact Us 
 
Website: http://www.datarizer.co.za 
 
E-mail:  info@datarizer.co.za or 
   
Contact: Lesley Baloyi 
 
Telephone: +27 11-466-0245 
 
Cell:  +27 72-625-7662 
 
Fax number: +27 86-688-5128 
 
Alternatively contact:  
 
Dade Mbhele on  +27 82 885 0813 
 

 

Datarizer 


